Android Studio版本兼容Api警告

Android Studio版本兼容Api警告

最近在开发中,组内的小伙伴在开发中使用了高版本SDK25的Api,但是我们的项目最低兼容14,因此测试在5.1上的手机直接就崩溃了,问其在开发中没有看到警告吗,回复说确实没看到.后来查究一下,他的工具上确实没有显示.本文简述下如何手动去调整兼容Api的提示等级,避免在开发中用到高版本的Api却不自察.

首先win电脑是打开Android StudioSetting ,mac是打开Android StudioPreferences

选择Editor中的InspectionsCalling new methods on older versions进行勾选并且配置为Error级别

如此简单即可搞定.如遇到其他警告,错误代码没提示也可类似进行操作配置.

0%